Probleme SW2013 et DAO360.DLL

vos questions concernant les API SolidWorks

Probleme SW2013 et DAO360.DLL

Messagepar MarcS » Lun 11 Fév 2013, 15:58

Attention il semble avoir un problème si vous utilisez DAO360.dll pour vous connecter a une base de données
et SW3013 et même avec le SP2.

Si vous avez un autres alternative a ce problème je suis intéressé

Merci
MarcS

Si je te donne un poisson tu pourras manger Aujourd’hui
mais si je t’apprend a pêcher tu pourras manger toute ta vie !!!
Salut !

Marc S.
Avatar de l’utilisateur
MarcS
Chevalier Jedi SolidWorks
 
Messages: 311
Inscription: Mar 06 Jan 2009, 20:10
Localisation: Quebec, Quebec SolidWorks 2017 SP 1.0 & SolidWorks 2014 SP 2.0

Re: Probleme SW2013 et DAO360.DLL

Messagepar Starck » Mar 19 Fév 2013, 21:59

Bonsoir,

Je prend le problème de l'extérieur et j'ai du mal à voir où est le soucis.
Pouvez vous être plus précis concernant ce soucis.
Est ce lors de l'execution ? l'ajout de la référence ? etc ...

++
Starck
Ewok SolidWorks
 
Messages: 37
Inscription: Lun 24 Déc 2012, 11:16

Re: Probleme SW2013 et DAO360.DLL

Messagepar MarcS » Mer 20 Fév 2013, 14:13

Lors de l'execution a l'ouverture de la base de données
Il donne une erreur d'activeX
Set Db = OpenDatabase("Mon_Fichier.mdb")

Si je te donne un poisson tu pourras manger Aujourd’hui
mais si je t’apprend a pêcher tu pourras manger toute ta vie !!!
Salut !

Marc S.
Avatar de l’utilisateur
MarcS
Chevalier Jedi SolidWorks
 
Messages: 311
Inscription: Mar 06 Jan 2009, 20:10
Localisation: Quebec, Quebec SolidWorks 2017 SP 1.0 & SolidWorks 2014 SP 2.0

Re: Probleme SW2013 et DAO360.DLL

Messagepar Starck » Mer 20 Fév 2013, 22:58

Bonjour,

As-tu testé de réenregistrer ta dll via la commande regsvr32 ?

Tu ouvres l'invite de cmd

En 32 bit :
Et tu mets : REGSVR32 "C:\Program Files\Common Files\Microsoft Shared\DAO\dao360.dll"

En 64 bits :
Et tu mets : REGSVR32 "C:\Program Files (x86)\Common Files\microsoft shared\DAO\dao360.dll"

Et tu valides.

++
Starck
Ewok SolidWorks
 
Messages: 37
Inscription: Lun 24 Déc 2012, 11:16

Re: Probleme SW2013 et DAO360.DLL

Messagepar MarcS » Jeu 21 Fév 2013, 16:14

Est-ce qu'il fonction de ton coté avec SW2013
Car ce DLL fonction très bien avec d'autres application

Et oui le DLL est enregistrer la preuve je l'utilise dans d'autres applications

Marc

Si je te donne un poisson tu pourras manger Aujourd’hui
mais si je t’apprend a pêcher tu pourras manger toute ta vie !!!
Salut !

Marc S.
Avatar de l’utilisateur
MarcS
Chevalier Jedi SolidWorks
 
Messages: 311
Inscription: Mar 06 Jan 2009, 20:10
Localisation: Quebec, Quebec SolidWorks 2017 SP 1.0 & SolidWorks 2014 SP 2.0


Retourner vers Questions générales sur les API

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 5 invités

banniere