Pièce transparente sous animator [Résolu]

Vos questions sur Cosmos, photoworks animator, E-Drawings, ....

Pièce transparente sous animator [Résolu]

Messagepar nicomo21 » Mar 19 Juin 2007, 15:33

Amis du jour Bonjour ou plutôt du soir bonsoir!! :wink:

Je voudrais réaliser une animation avec une pièce transparente pour pouvoir voir celle qui ce cache derrière!
J'essaie de modifier l'apparence de ma pièce mais en-vin! :oops: :?

Merci pour votre aide! :)
Dernière édition par nicomo21 le Mar 19 Juin 2007, 15:41, édité 1 fois.
Avatar de l’utilisateur
nicomo21
Chevalier Jedi SolidWorks
 
Messages: 408
Inscription: Jeu 19 Avr 2007, 13:11
Localisation: Montrouge

Messagepar dgé² » Mar 19 Juin 2007, 15:38

dans animator, tu peux derouler les proprieté visuelle d'une piece dans le temps, mais c'est ou tout ou rien.... par contre si tu supprime toutes les proprietées visuelle misent dans l'assemblage sur ta piece et que tu change l'apparence de la piece dans la piece, ca devrait marcher...
lles differentes interference qui peuvent te jouer des tours:
l'option afficher les materiaux PW dans solid
l'option utiliser les proprieté physique de solid dans PW
les differentes apparence d'une même piece (assemblage ou piece)
et aprés c'est surtout du au limites d'animator...

t'as essayé de faire dans l'assemblage modifier la transparence?
dgé²
Esprit Jedi Solidworks
 
Messages: 3987
Inscription: Lun 22 Jan 2007, 18:10
Localisation: lyon 2011 sp3 win7 x64

Messagepar nicomo21 » Mar 19 Juin 2007, 15:41

C'est bon ça marche, je sais pas trop pourquoi mais enfin!!
En fait j'ai fait un petit coup de "repère d'apparence" et je ne sais pas pourquoi mais ma pièce avait un couleur entant que pièce et une autre entant qu'assemblage! :roll:
Bien joué dgé²
Merci de la rapidité de réponse!
:wink:
Avatar de l’utilisateur
nicomo21
Chevalier Jedi SolidWorks
 
Messages: 408
Inscription: Jeu 19 Avr 2007, 13:11
Localisation: Montrouge

Messagepar dgé² » Mar 19 Juin 2007, 15:43

well done :wink:
et de rien pour la reponse tu imagine bien que je ne suis pas arrivé a ca sans avoir moi même experimenté le pb un bon bout de temps avant de trouver la solution... :lol:
dgé²
Esprit Jedi Solidworks
 
Messages: 3987
Inscription: Lun 22 Jan 2007, 18:10
Localisation: lyon 2011 sp3 win7 x64

Messagepar John Doe » Ven 20 Juin 2008, 15:30

Evil Evil Evil

Alors même soucis, mais pas résolu. Je me bats contre les textures et couleurs parasites mais rien n'y fait. Je vois la même chose que Nico avec le repère d'apparence, mais j'ai pas trouvé comment enlever la couleur de trop (au niveau assemblage).

Bizarrement la seule pièce qui foire est celle servant de base de départ à l'assemblage.


En espérant que tout le monde n'est pas déjà en weekend. ^^'

Edit pour M. Dgé^2 : Bah la même que Nico en fait, j'ai repris son poste :mrgreen: , 2007 SP4.0
Dernière édition par John Doe le Ven 20 Juin 2008, 16:58, édité 1 fois.
Avatar de l’utilisateur
John Doe
Chevalier Jedi SolidWorks
 
Messages: 239
Inscription: Mer 05 Mar 2008, 11:19
Localisation: Montpellier - Nimes

Messagepar dgé² » Ven 20 Juin 2008, 16:55

t'es sous quelle version de solid :D
dgé²
Esprit Jedi Solidworks
 
Messages: 3987
Inscription: Lun 22 Jan 2007, 18:10
Localisation: lyon 2011 sp3 win7 x64

Messagepar dgé² » Ven 20 Juin 2008, 17:11

alors j'ai eu le pb souvent avec 2007... en gros y'a un p***** de bug au niveau de la gestion des apparance et des conflicts entre apparence par face (prioritaire sur les autres normalement...) apparance par fonction (priorité de rang 2) apparance par corps (priorité de rang3) par piece (dans la piece toujours priorité de rang 4) et enfin dans l'assemblage priorité de rang 3.5.....
donc en gros faut que t'ouvre la piece, que tu edote tes reperes d'apparance, si possible tu selectionne une fois une face apparance supprimer la couleur puis suppriimer toute les couleur idem pour les fonction et les corps, supprime aussi toutes les apparence de ta piece dans l'assemblage, et vois celle que tu n'arrive pas a supprimer est resoponsable du bug... la derniere fois que j'ais eu a me battre avec solid a ce sujet, il a fallut que je ferme la piece et que je la reouvre pour voir les modif effectivement s'appliquer... c'est a devenir dingue. sinon si tu ne veux pas perdre de temps, tu enregistre ta piece en parasolid, tu l(importe sous un autre nom ou tu dupplique le corps dans ta piece (en décochant conserver les prop visuelle) et tu fait ton anim avec ca....
dgé²
Esprit Jedi Solidworks
 
Messages: 3987
Inscription: Lun 22 Jan 2007, 18:10
Localisation: lyon 2011 sp3 win7 x64

Messagepar John Doe » Ven 20 Juin 2008, 17:33

Je vais analyser ça.

J'ai réussi à contourner mon problème, en jouant sur les effets de transparence dans les couleurs plutôt que dans les options d'affichage (filaire->ombré).( Bon le soucis c'est que j'arrive plus à retrouver mes textures du coup là. :mrgreen: )
Avatar de l’utilisateur
John Doe
Chevalier Jedi SolidWorks
 
Messages: 239
Inscription: Mer 05 Mar 2008, 11:19
Localisation: Montpellier - Nimes

Messagepar dgé² » Ven 20 Juin 2008, 17:41

je sais pas si on peuft faire ca avec une piece texturée... je l'ais fairt que a partir d'apparence couleur... :|
dgé²
Esprit Jedi Solidworks
 
Messages: 3987
Inscription: Lun 22 Jan 2007, 18:10
Localisation: lyon 2011 sp3 win7 x64

Messagepar John Doe » Lun 23 Juin 2008, 16:40

J'ai finalement opté pour l'export-réimport en parasolid. ça roule nickel chrome.

De même pour les textures, en laissant la case "afficher les couleurs SW dans PW", et en enregistrant dans Animator avec l'option PW.

Le site du produit est encore en cours de construction donc vous ne pourrez pas voir le résultat tout de suite, mais ça ne saurait tarder.

Merci encore Dgé !
Avatar de l’utilisateur
John Doe
Chevalier Jedi SolidWorks
 
Messages: 239
Inscription: Mer 05 Mar 2008, 11:19
Localisation: Montpellier - Nimes

Messagepar dgé² » Lun 23 Juin 2008, 17:11

pas de souchis :wink:
dgé²
Esprit Jedi Solidworks
 
Messages: 3987
Inscription: Lun 22 Jan 2007, 18:10
Localisation: lyon 2011 sp3 win7 x64


Retourner vers SolidWorks : Adds-on et produit partenaires

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

banniere