Pb avec fonction repetition circulaire

Vous pouvez echanger sur les fonctionnalités générales du logiciel.

Pb avec fonction repetition circulaire

Messagepar Sky » Jeu 02 Avr 2015, 7:39

Bonjour à tous,

J'ai une pièce réalisée avec la fonction "construction soudée". Une fois la structure montée, je fait quelques trous avec la fonction "enlèvement de matière extrudée". Je trace une ligne de construction dans une esquisse pour matérialiser l'axe de rotation. Puis j'utilise la fonction "répétition circulaire", en désignant l'axe puis la fonction.
Et je m'aperçois alors que ma fonction ne tourne pas autour de l'axe que j'ai désigné, mais autour d'un axe qui est à 90° de l'axe que j'ai désigné... (?????). Si je dessine l'axe au même endroit, mais dans un plan différent, au final la fonction se fait aussi à 90° de l'axe, mais de l'autre coté (à 90° du premier essai). J'ai l'impression qu'il y a un mélange des axes.
Quelqu'un saurait-il m'aider à faire marcher cette fonction? Merci pour l'aide.
Avatar de l’utilisateur
Sky
Ewok SolidWorks
 
Messages: 36
Inscription: Ven 30 Mar 2012, 10:54
Localisation: Savigny le Temple (77) - SW2010

Re: Pb avec fonction repetition circulaire

Messagepar Sky » Jeu 02 Avr 2015, 8:12

Il n'y a pas que le rotations qui merdent, mais il y a aussi les symétries. Toute fonction que j'essaie de symétriser par un plan ne se fait pas au bon endroit...
Avatar de l’utilisateur
Sky
Ewok SolidWorks
 
Messages: 36
Inscription: Ven 30 Mar 2012, 10:54
Localisation: Savigny le Temple (77) - SW2010

Re: Pb avec fonction repetition circulaire

Messagepar Scrutch » Jeu 02 Avr 2015, 9:04

ça sent le bug ça... tu as contacté ton revendeur?
Scrutch
Padawan SolidWorks
 
Messages: 162
Inscription: Lun 23 Sep 2013, 10:31

Re: Pb avec fonction repetition circulaire

Messagepar gt22 » Jeu 02 Avr 2015, 9:07

des copies d’écran seraient plus parlantes :wink:
Avatar de l’utilisateur
gt22
Padawan SolidWorks
 
Messages: 198
Inscription: Ven 10 Juin 2011, 19:29

Re: Pb avec fonction repetition circulaire

Messagepar Scrutch » Jeu 02 Avr 2015, 9:07

ou méme la pièce ;)
Scrutch
Padawan SolidWorks
 
Messages: 162
Inscription: Lun 23 Sep 2013, 10:31

Re: Pb avec fonction repetition circulaire

Messagepar gt22 » Jeu 02 Avr 2015, 9:12

oui mais on a pas tous la même version de SW :roll:
Avatar de l’utilisateur
gt22
Padawan SolidWorks
 
Messages: 198
Inscription: Ven 10 Juin 2011, 19:29

Re: Pb avec fonction repetition circulaire

Messagepar Scrutch » Jeu 02 Avr 2015, 9:22

c'est vrai, c'est relou ça

après, moi ça va je suis sur 2015 donc je devrai pas avoir trop de problème
Scrutch
Padawan SolidWorks
 
Messages: 162
Inscription: Lun 23 Sep 2013, 10:31

Re: Pb avec fonction repetition circulaire

Messagepar Sky » Ven 03 Avr 2015, 8:13

Je viens de faire quelques essais:
- J'ai refait une pièce mécano soudée plus simple => même pb
- J'ai fait cette pièce sur le sw2012 d'un copain => idem

Si je fait une répétition circulaire avec un axe issu d'une géométrie de référence => la visu (en jaune avant validation) est bonne, mais validation impossible. Si je fais avec axe issu d'un trait de construction dans une esquisse, même la visu avant validation est mauvaise.

Vu que le pb existe sur sw2010 et sur sw2012, je pense pas qu'il s'agisse d'un bug, mais plutôt d'un problème d'utilisation de ma part, mais franchement je sèche. C'est chiant de bloquer sur une fonction si simple...

Image

Image

Je vous ai dit que les symétries merdaient elles aussi. En fait, ce n'est pas tout à fait exact: la symétrie de la fonction via le plan de droite marche. Par contre, celle via le plan de face ou de dessus ne marchent pas...

Et si vous voulez vous amuser, voici le fichier:
http://www.astrosurf.com/sogorb/stock/test.SLDPRT

merci pour l'aide.
Dernière édition par Sky le Ven 03 Avr 2015, 8:24, édité 2 fois.
Avatar de l’utilisateur
Sky
Ewok SolidWorks
 
Messages: 36
Inscription: Ven 30 Mar 2012, 10:54
Localisation: Savigny le Temple (77) - SW2010

Re: Pb avec fonction repetition circulaire

Messagepar Scrutch » Ven 03 Avr 2015, 8:15

j'ai deja eu ça, j'avais contacté mon revendeur, c'est un bug

il faut utilisé le trait d'esquisse il me semble. après, si tu ne peux pas valider alors que la fonction à l'air propre, vérifie que tu n'as pas coché répétition de géométrie dans ta fonction
Scrutch
Padawan SolidWorks
 
Messages: 162
Inscription: Lun 23 Sep 2013, 10:31

Re: Pb avec fonction repetition circulaire

Messagepar Sky » Ven 03 Avr 2015, 15:57

Merci pour l'info. Ce bug existe aussi sur les versions suivantes?
Avatar de l’utilisateur
Sky
Ewok SolidWorks
 
Messages: 36
Inscription: Ven 30 Mar 2012, 10:54
Localisation: Savigny le Temple (77) - SW2010

Re: Pb avec fonction repetition circulaire

Messagepar Scrutch » Ven 03 Avr 2015, 16:09

non pas sur 2015 a priori. c'est ok avec l'axe, par contre via une ligne de construction dans une esquisse j'ai impression qu'il prend la normale au plan d'esquisse comme référence
Scrutch
Padawan SolidWorks
 
Messages: 162
Inscription: Lun 23 Sep 2013, 10:31


Retourner vers SolidWorks : Questions générales

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 12 invités

banniere