Propriétés personalisées pour les pièces de la toolbox

Toutes vos questions concernant la bibliothèque de pièces de Solidworks.

Propriétés personalisées pour les pièces de la toolbox

Messagepar Uncle Buzz » Mar 26 Aoû 2008, 8:58

Bonjour,

Sur la version SW2005, j'ajoutais des propriétés personnalisées aux fichier toolbox pour faire apparaitre certaines informations dans mes nomenclatures plus parlantes que les normes DIN ou autres.

Lorsque j'ajoutais la définition de ces propriétés dans le configurateur des pièces toolbox, celles-ci n'étaient prises en compte que lors de l'ajout de nouvelle occurrence de ces pièces toolbox (chaque insertion d'une pièce toolbox recalcule la configuration dans le fichier toolbox), les pièces déjà insérées utilisant la configuration calculée lors de leur insertion.
Mais si j'utilisais le clic droit sur ma pièce toolbox, et que je choisissais d' "éditer la définition toolbox" en rechoisissant la taille déjà utilisée, alors SW2005 recalculai la configuration et lui appliquait alors les propriétés personnalisées.

Depuis que je suis passé à la version SW2008, j'ai toujours les propriétés personnalisées déjà définies, mais si j'en crée de nouvelles, lorsque je demande "éditer la définition toolbox" d'une pièce déjà insérée, SW2008 ne recalcule plus les configurations déjà créées, et donc ne m'ajoute pas les propriétés personnalisées pour toutes les configurations que j'ai déjà créées dans mes assemblages.

Avez-vous constaté le même fonctionnement, et savez-vous comment retrouver le fonctionnement de la version SW2005 ? (je suis passé directement de SW2005 à SW2008)
Uncle Buzz
Padawan SolidWorks
 
Messages: 117
Inscription: Mar 26 Aoû 2008, 8:40
Localisation: La Courneuve SW2010 SP2.0

Messagepar Dessinator » Mar 26 Aoû 2008, 9:14

C'est bizarre j'ai vu le meme probléme sur un autre forum avec le meme pseudo :lol: :lol:
SolidWorks. What else?
L'aide en ligne est ton amie
Avatar de l’utilisateur
Dessinator
Membres du Conseil SolidWorks
 
Messages: 1632
Inscription: Sam 09 Fév 2008, 18:08
Localisation: Arras-------- SW2011 SP1.0_XP64

Messagepar Uncle Buzz » Mar 26 Aoû 2008, 10:28

Comment ça je mange à tous les râteliers ? :lol:

Ben suivant les affinités, certaines communauté n'aime pas se mélanger, ou reste à l'endroit où elles ont leur habitudes...

Moi je ne suis pas raciste, peu importe d'où vient la solution, du moment qu'elle vienne 8)

PS: n'oublie pas de me prévenir si on me répond là-bas :lol:
Uncle Buzz
Padawan SolidWorks
 
Messages: 117
Inscription: Mar 26 Aoû 2008, 8:40
Localisation: La Courneuve SW2010 SP2.0

Messagepar Dessinator » Mar 26 Aoû 2008, 10:31

A mon avis tu as plus de chance d'avoir une réponse ici 8)
SolidWorks. What else?
L'aide en ligne est ton amie
Avatar de l’utilisateur
Dessinator
Membres du Conseil SolidWorks
 
Messages: 1632
Inscription: Sam 09 Fév 2008, 18:08
Localisation: Arras-------- SW2011 SP1.0_XP64

Messagepar 8wd » Mar 26 Aoû 2008, 10:40

Dessinator a écrit:A mon avis tu as plus de chance d'avoir une réponse ici 8)

+1 :D

D'ailleurs, je ne connais pas d'autres endroit. Tu disais que certains avaient leurs affinités?! .. je confirme !!! :twisted_evil:
8wd
Esprit Jedi Solidworks
 
Messages: 4247
Inscription: Mer 12 Avr 2006, 16:04
Localisation: Marseille - SW2011_5.0 - Win7x64

Messagepar Uncle Buzz » Jeu 04 Sep 2008, 14:55

Bon apparemment il s'agit d'un vilain bug au moins présent dans la 2008 et par conséquent la 2009...

donc SolidWorks bosse dessus et la correction devrait arriver dans un SP pour la 2008 et avant la version final en 2009 (si elle est pas déjà disponible).

A croire que personne n'utilise la toolbox (en même temps vu la documentation sur le sujet ça aide pas bien)
Uncle Buzz
Padawan SolidWorks
 
Messages: 117
Inscription: Mar 26 Aoû 2008, 8:40
Localisation: La Courneuve SW2010 SP2.0

Messagepar Yoshimi » Ven 05 Sep 2008, 7:01

Bah pour ma pars je "découvre" SW, enfin, j'en découvre les réelles fonctionalités, et je trouve vraiment dommage que les outils puissant tels que la tool box, le smart fastener, l'assistant pour le perçage,... aient été développé avec aussi peu de bon bon sens, ils en deviennent difficilement utilisable pour les mecs tels que moi qui on une connaissance limité en programmation et en langage informatique ou qui s'y mettent.

Je suis sur qu'en étudiant à fond leur fonctionnement, y'a moyen de se simplifier grandement la vie, même si la mise en place est compliqué, mais ça demande trop de temps, et en général au boulot, le temps on en a pas pour ça :).
Avatar de l’utilisateur
Yoshimi
Padawan SolidWorks
 
Messages: 76
Inscription: Mar 22 Juil 2008, 13:52

Messagepar Dessinator » Mer 24 Sep 2008, 16:34

Salut,

@Uncle Buzz: je viens d'utiliser ton tuto pour les propriétés personalisées de la toolbox, et je trouve cela génial, c'est juste ce qu'il me fallait.

Pour le probléme des pièces déjà insérées, j'édite le Smart Fastener, je re sélectionne mon type de vis, et la SW me met à jour la config, et prend en compte les propriétés que j'ai rajoutées.

As-tu essayé?

A+
SolidWorks. What else?
L'aide en ligne est ton amie
Avatar de l’utilisateur
Dessinator
Membres du Conseil SolidWorks
 
Messages: 1632
Inscription: Sam 09 Fév 2008, 18:08
Localisation: Arras-------- SW2011 SP1.0_XP64

Messagepar Uncle Buzz » Mar 14 Oct 2008, 11:14

Je n'utilise pas le smart fastener, uniquement la toolbox en direct, et celà marchait en 2005, plus en 2008 (ni 2009 d'après le technicien) et ce serait un bug.

Content que le tuto t'ai servit ;)
Uncle Buzz
Padawan SolidWorks
 
Messages: 117
Inscription: Mar 26 Aoû 2008, 8:40
Localisation: La Courneuve SW2010 SP2.0

Re: Propriétés personalisées pour les pièces de la toolbox

Messagepar Uncle Buzz » Mer 20 Mai 2015, 10:58

Bonjour à tous,

Petite réapparition pour signaler qu'en version 2015, tout est de nouveau parfaitement fonctionnel !
Uncle Buzz
Padawan SolidWorks
 
Messages: 117
Inscription: Mar 26 Aoû 2008, 8:40
Localisation: La Courneuve SW2010 SP2.0


Retourner vers Toolbox

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

banniere